Skip to content

Management Server fails to start on new install #11588

Description

@iloving

problem

Followed the instructions to create a new management server with a separate mysql server. Like many others, the server fails to start. When I try to go to http::8080, I get:

HTTP ERROR 503 Service Unavailable

URI: /client/
503
Service Unavailable

When I look at the logs, I see multiple errors, although the two that stick out for me are:
management-server.out: lots of

2025-09-05 22:24:28,011 main ERROR TcpSocketManager (TCP:localhost:4560) caught exception and will continue: java.io.IOException: Unable to create socket for localhost at port 4560 using ip address 127.0.0.1 and port 4560

management-server.log:
Unhandled configuration exception: The script injectkeys.sh failed to run successfully : Files /var/lib/cloudstack/management/.ssh/id_rsa and /usr/share/cloudstack-common/scripts/vm/systemvm/id_rsa.cloud differsudo: a password is required

2025-09-05 22:26:17,543 DEBUG [o.a.c.s.m.m.i.DefaultModuleDefinitionSet] (main:[]) (logid:) module start failure of module [core] was due to: org.springframework.context.ApplicationContextException: Failed to start bean 'cloudStackLifeCycle'; nested exception is com.cloud.utils.exception.CloudRuntimeException: Unhandled configuration exception

tons of module load errors for various modules such as:
2025-09-05 22:26:17,604 WARN [o.a.c.s.m.m.i.DefaultModuleDefinitionSet] (main:[]) (logid:) Failed to start module [allocator] due to: [Error creating bean with name 'org.springframework.beans.factory.config.PropertyPlaceholderConfigurer#0' defined in URL [jar:file:/usr/share/cloudstack-management/lib/cloudstack-4.21.0.0.jar!/META-INF/cloudstack/bootstrap/spring-bootstrap-context-inheritable.xml]: Cannot resolve reference to bean 'DefaultConfigResources' while setting bean property 'locations'; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named 'DefaultConfigResources' available].

This appears to be the same problem someone else had, but it doesn't look like it went anywhere. #11534 (reply in thread)

versions

ACS: v4.21
mysql: 8.0.43-0ubuntu0.22.04.1
Running on a Ubuntu 22.04 under VMWare Cloud.
1 nic

The steps to reproduce the bug

  1. Install the server as per instructions

What to do about it?

Cloudstack is currently unusable out of the box.

I have attached:
-all the logs generated by the server
-a screen capture of the terminal
-the script I use to do the installation of cloudstack

screenshot.txt

install-cloudstack1.sh

logs.tgz

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions