Skip to content

VR suddenly was created with DHCP Service Failing. Can we Implement an auto-recovery? #10932

Description

@btzq

problem

One of our users created a VPC and was complaining about how they were not able to get a private IP.

When we checked, turns out dhcp service was down. This surprised us because usually the VR is created without issues, and suddenly this happens.

Attached screenshot below:

Image

Questions:

  • Why is it that suddenly a service fails when a new VR is created, when we usually dont have issues with VR creation all this while?
  • When VR detects a service is down, can it also restart that specific service in the VR without having to reboot or cleanup the VR? This would be more automatic and less downtime/issues.

versions

Cloudstack Version: 4.19.1.1
Storage: Linstor DRBD
Architecture: Disaggregated
Hypervisor: Ubuntu

The steps to reproduce the bug

Cant give a step. Just happens randomly when a new VPC is created.

What to do about it?

When VR detects a service is down, auto estart that specific service in the VR without having to reboot or cleanup the VR? This would be more automatic and less downtime/issues.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions