Skip to content

Proposal for minimal GNAP support. - #57

Open
handrews wants to merge 5 commits into
OAI:mainfrom
handrews:minimal-gnap
Open

handrews wants to merge 5 commits into
OAI:mainfrom
handrews:minimal-gnap

Conversation

@handrews

Copy link
Copy Markdown
Member

This adds minimal GNAP support using access reference strings to the existing Security Scheme Object and Security Requirement Object.

Using Resource Access Rights (RAR) in place of reference strings is being addressed in a companion specification, coming soon.

This adds minimal GNAP support using access reference strings
to the existing Security Scheme Object and Security Requirement Object.

Resource Access Rights (in place of reference strings) are being
addressed in a companion specification.
I blame a syntax highlighting bug.
Comment thread proposals/2026-10-15-Minimal-GNAP.md Outdated

Defines a security scheme that can be used by the operations.

Supported schemes are HTTP authentication, an API key (either as a header, a cookie parameter or as a query parameter), mutual TLS (use of a client certificate), OAuth2’s common flows (implicit, password, client credentials and authorization code) as defined in [RFC6749], OAuth2 device authorization flow as defined in [RFC8628], [OpenID-Connect-Core], and GNAP as defined in [RFC9635].

Copy link
Copy Markdown
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

aren't the URIs missing for this paragraph?

@handrews handrews Oct 16, 2026 •

Copy link
Copy Markdown
Member Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@baywet I'm just showing the text changes, not producing a renderables specification excerpt.

Copy link
Copy Markdown
Member Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Oh, I see what you mean. No, [RFC8628] is not missing a URI, it is resolved through the SpecRef system.

Copy link
Copy Markdown
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

thanks for clarifying. This can be resolved (I don't have permissions)

Comment thread proposals/2026-10-15-Minimal-GNAP.md Outdated
Comment thread proposals/2026-10-15-Minimal-GNAP.md Outdated
Comment thread proposals/2026-10-15-Minimal-GNAP.md Outdated
Comment thread proposals/2026-10-15-Minimal-GNAP.md Outdated
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants